martes, 1 de mayo de 2012

LMDE a punto!

Como dije anteriormente, hoy voy a dar una serie de pautas y tips para dejar LMDE en perfecto funcionamiento.

Se tratarán los siguientes temas:

-Idiomas de firefox, libreoffice y thunderbird.
-Problemas con compiz y consumo CPU
-Abrir carpeta contenedora de Firefox no funciona.
-Añadir buscador google a la barra de herramientas.
-Al presionar botón de apagado sale el menú de apagar, pero se apaga sin darte a elegir.
-No se oscurece la pantalla al estar en modo batería.

Idiomas

Firefox y libreoffice aparecen en inglés así que añadimos las locales en es-ES

En una terminal poned:

sudo apt-get install firefox-l10n-es libreoffice-l10n-es thunderbird-l10n-es

Para añadir el corrector para libreoffice:
sudo apt-get install aspell aspell-es

Corrector para otros programas como emesene o pidgin:
sudo apt-get install python-gtkspell


Si por cualquier motivo en libre-office no se corrigiesen las palabras en español, podéis añadir el módulo desde aquí:
http://extensions.libreoffice.org/extension-center/diccionario-espanol
Lo descargáis, pincháis dos veces y os saldrá el administrador de módulos de libre-office, lo añadís y listo.
Si siguiese sin funcionar, revisad la configuración de idioma en Herramientas > Opciones > Configuración de Idioma y finalmente en "Asistencia en la escritura"


Compiz
Si activamos compiz veremos que algunas veces no funciona bien, o no carga los bordes de pantalla.... además, consume mucha cpu al entrar en conflicto con marco (el decorador de ventanas de mate)

Para esto hay dos posibles soluciones.

1ª solución:

Problemas con compiz:
marco y compiz entran en conflicto y consumen más CPU de lo habitual.
Lo mejor es parar marco y dejar compiz, ya que este último hace su labor sin necesidad de marco.

Para que veáis lo que os digo, y comprovéis que es así, quiero que abráis el "monitor del sistema" (menú de la barra de mate)

Posisionaros en la pestaña recursos y veréis (si no estáis haciendo uso del ordenador) que la CPU está algo alta... no cerréis el monitor de sistema:

Si ya tenéis compiz activado y funcionando quiero que abráis una terminal y pongáis:
sudo killall marco
Y justo cuando el comando haga efecto fijaros el consumo de CPU
¿Bajó? pues tenéis que impedir que marco se ejecute al inicio.
No se os ocurra desintalarlo... porque se lleva el escritorio al traste.

Procedemos así:
Abrimos el menú y buscando "aplicaciones al inicio"
Y añadimos dos nuevas aplicaciones:

-1ª
Nombre: Parar marco
Comando: killall marco
Comentario: Para evitar conflictos con compiz

-2º
Nombre: Compiz
Comando: compiz --replace
Comentario: Activación de Compiz y sus Efectos

Segunda solución publicada en:

http://ubuntu-cosillas.blogspot.com.es/2012/05/solucionar-mate-y-compiz-ii.html

Cito textualmente:
Hacer que Compiz remplace a marco

Abrimos el editor de configuración de MATE desde un terminal o desde su lanzador que se debería encontrar en el menú Aplicaciones/ Herramientas del sistema/Editor de Configuración.
Para ejecutarlo desde el terminal lo haremos así:
  • mateconf-editor
Si no lo tienes, instálalo así:
  • sudo apt-get install mate-conf-editor
Una vez abierto nos movemos hasta la siguiente rama y cambiamos su valor de este:
/desktop/mate /session/required_components /windowmanager marco
a este otro:
/desktop/mate /session/required_components /windowmanager compiz



Luego por último creamos un Aplicación al Inicio con el siguiente comando:
compiz ccp

Cerramos sesión y volvemos a entrar, y debería funcionar perfectamente.
Desde luego con esta pequeña modificación se nota considerablemente mucha más estabilidad de MATE con Compiz.


Problemas con Firefox

El idioma ya lo hemos arreglado arriba..... ahora toca otras cosillas.

Motor de búsqueda de firefox... si os fijáis no está google, esto es porque es una marca comercial.
Lo añadimos fácilmente yendo a la siguiente dirección:

http://www.linuxmint.com/searchengines.php

Y una vez allí bajáis hasta localizar "Commercial engines" y pincháis en el logo de google.
Cargará otra página php que os dará la opción de instalar el motor de google.

En vuestro navegador firefox, mirad en el símbolo de la flechita del diálogo de búsqueda (Aparece yahoo por defecto) para desplegar los buscadores disponibles y..... ¡Anda! ¡Si aparece añadir google!
Pues listo, le dais a añadir google y ya lo tenéis puesto por defecto.

Otro problema en firefox es que no puedes abrir la carpeta contenedora desde la ventana "descargas" porque te pide aplicación.
La aplicación con la que navegas por los directorios en mate se llama "caja"
Así que cuando os pida la aplicación, solo tenéis que ir a /usr/bin/ y seleccionar el archivo "caja" le dais a aceptar, marcáis la casilla de recordar y volvéis a aceptar, se deberá de abrir la carpeta de descargas.



Por cierto abrid firefox, iros por ejemplo.... a google, y botón derecho sobre una caja de texto cualquiera del buscador y activáis "revisar ortografía", luego volvéis ha hacerlo y mirais en "idiomas" a ver si está en español, si está en otro idioma solo tenéis que añadir el español con el botón de añadir.


Botón de apagado

Pues eso, cuando presionas el botón de apagado, mucha gente lo que pretende es que le salga el menú de apagar, suspender o reiniciar.

Pues bien, el mensaje te sale si, pero te ignora y en menos de 2 segundos el pc se apaga.

Esto es porque el botón está programado para mostrar el menú de "apagar,reiniciar y suspender" pero tambien está programado por ACPI para apagar el pc de manera automática.

Se soluciona muy fácilmente.

Abrís una terminal y escribid:
sudo nano /etc/acpi/events/powerbtn-acpi-support

Se os abrirá el archivo "powerbtn-acpi-support" con el ditor de texto nano.
Dentro hay dos lineas que tenemos que comentar (Poner almohadillas delante):

#event=button[ /]power
#action=/etc/acpi/powerbtn-acpi-support.sh

Eso evitará que se apague mediante evento ACPI, que es lo que estaba ocurriendo.

Para guardar el archivo presiona Ctrl+o y confirma con Intro, luego presiona CTRL+x.

Para esta sesión no funcionará, pero para la próxima vez no tendrás problema en elegir una opción tras presionar el botón power físico del pc.


Antenuar pantalla en modo batería

Para esto hay dos posibles soluciones porque el problema puede ser por varias razones.

Razón 1ª:

El antenuador de pantalla en el menú de administración de energía funciona, pero internamente la atenuación tiene un valor 0, así que vamos a revisar eso.

Instala el mateconf-editor

sudo apt-get install mate-conf-editor

Cuando lo tengas ve a:
Menú > Herramientas de sistema > Editor de configuración

Busca el apartado:
/apps/mate-power-manager/backlight/

Y fíjate el valor de brightness_dim_battery

Digamos que la atenuación de la pantalla tiene un valor de 50% de reducción de brillo.

Si el valor lo pones a 0 no se atenúa la pantalla nada de ese 50% , y si lo pones hasta el maximo, que es 100 la pantalla se oscurecerá al 50%

Ha sido una solución a la que he podido llegar.

Pero otro motivo, (y aquí viene la otra posible razón)  es que hayamos instalado drivers privativos, y estos tienden a tomar el control del brillo de pantalla, así que para arreglar esto antes de nada hay que agradecer a Senekis que haya publicado la solución en su blog http://elmundodesenekis.wordpress.com/author/johannasenekis/

La solución parte por editar el archivo /etc/X11/xorg.conf

sudo nano /etc/X11/xorg.conf

Y buscar la sección Device, para añadir justo antes del final de esa sección la instrucción:

Option "RegistryDwords" "EnableBrightnessControl=1"

De manera que quede algo parecido a esto:

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Echo eso, presionamos Ctrl+o y presionamos enter para guardar, y para salir Ctrl+x

Un saludo y espero que todo os vaya bien.

3 comentarios:

  1. Funciono perfecto para mi

    ResponderEliminar
  2. Me alegro que te funcionara.

    Un saludo.

    ResponderEliminar
  3. amigo gracias por este tuto pero tengo un problema cuando desabilito mate y agrego compiz todo va de maravilla lo unico que no puedo es mover las ventanas
    es decir si funcionan los botones minimizar maximizar cerrar pero no puedo mover las ventanas con el mouse donde aprece ahi se queda y no puedo moverlo para un costado nose que hacer

    ResponderEliminar

Deja aquí tu mensaje...